جهت استفاده از تمامی امکانات تارنمای انجمن (ایجاد موضوع،دانلود فایل و ...) لازم است،عضویت یک ساله را خریداری فرمائید. برای این کار مبلغ 50 هزار تومان را به کارت 6221061059143315 واریز نموده،سپس نام کاربری خود را به شماره 09128921121 ارسال کنید. 01-07-1402


امتیاز موضوع:
  • 0 رأی - میانگین امتیازات: 0
  • 1
  • 2
  • 3
  • 4
  • 5
مشکل با نصب و راه اندازی پکیج مپنیک (برنامه نویسی جی آی اس در پایتون)
#1
سلام
من قصد نصب و استفاده از کتابخانه مپنیک در پایتون رو دارم اما ابتدا ارور No module found رو می گرفتم و بعد از طی مراحلی، الان آخرین اروری که می گیرم دقیقا اینه:
from _mapnik import *

ImportError: DLL load failed: The specified module could not be found.

کسی قبلا با این کتابخانه کار کرده و چنین اروری داشته؟
محیطم:
آناکوندا 2، مپنیک 2.2.0، ویندوز 8.1 64 بیتی
پاسخ
#2
(۰۹-۲۰-۱۳۹۸، ۰۶:۲۲ ب.ظ)parsley نوشته است: سلام
من قصد نصب و استفاده از کتابخانه مپنیک در پایتون رو دارم اما ابتدا ارور No module found رو می گرفتم و بعد از طی مراحلی، الان آخرین اروری که می گیرم دقیقا اینه:
from _mapnik import *

ImportError: DLL load failed: The specified module could not be found.

کسی قبلا با این کتابخانه کار کرده و چنین اروری داشته؟
محیطم:
آناکوندا 2، مپنیک 2.2.0، ویندوز 8.1 64 بیتی

با سلام
اگر میخواهید بدون هیچ مشکلی از پایتون و کتابخانه های آن استفاده کنید از سیستم عامل لینوکس استفاده کنید و اگر همچنان اصرار بر استفاده از ویندوز را دارید باید از پایتون 2.7 نسخه 32 بیتی استفاده کنید تا بتوانید از کلیه کتابخانه ها براحتی بهره ببرید. روش نصب mapnik هم در سایتهای مرتبط وجود دارد.
پاسخ
#3
ممنون البته من هم از پایتون 2.7 32 بیتی استفاده می کنم (درواقع بعد از بروز مشکل با پایتون و آناکوندا 3، نسخه 2 و 32 بیت رو هم نصب کردم) اتفاقا قبلا یکبار مپنیک رو روی همین نسخه نصب و استفاده کردم اما اینبار نمیدونم چرا این مشکل پیش اومده...
پاسخ
#4
(۰۹-۲۱-۱۳۹۸، ۰۸:۲۷ ب.ظ)alish نوشته است:
(۰۹-۲۰-۱۳۹۸، ۰۶:۲۲ ب.ظ)parsley نوشته است: سلام
من قصد نصب و استفاده از کتابخانه مپنیک در پایتون رو دارم اما ابتدا ارور No module found رو می گرفتم و بعد از طی مراحلی، الان آخرین اروری که می گیرم دقیقا اینه:
from _mapnik import *

ImportError: DLL load failed: The specified module could not be found.

کسی قبلا با این کتابخانه کار کرده و چنین اروری داشته؟
محیطم:
آناکوندا 2، مپنیک 2.2.0، ویندوز 8.1 64 بیتی

با سلام
اگر میخواهید بدون هیچ مشکلی از پایتون و کتابخانه های آن استفاده کنید از سیستم عامل لینوکس استفاده کنید و اگر همچنان اصرار بر استفاده از ویندوز را دارید باید از پایتون 2.7 نسخه 32 بیتی استفاده کنید تا بتوانید از کلیه کتابخانه ها براحتی بهره ببرید. روش نصب mapnik هم در سایتهای مرتبط وجود دارد.
و در مورد لینوکس هم اطلاع دارید که چطور میشه اونرو روی یک محیط مجازی بروی ویندوز نصب و استفاده کرد؟ و چه نسخه ای از اون بهتره؟ با تشکر
پاسخ


موضوعات مرتبط با این موضوع...
موضوع نویسنده پاسخ بازدید آخرین ارسال
  برنامه نویسی GIS در Silverlight piroozman 3 2,726 ۱۰-۲۲-۱۴۰۲، ۰۷:۱۱ ب.ظ
آخرین ارسال: فردین آژغ
  آموزش برنامه نویسی در محیط ARC-GIS ayob_f 1 1,937 ۱۰-۲۱-۱۴۰۲، ۱۰:۳۶ ق.ظ
آخرین ارسال: sonia.ahmadian79@gmail.com
  تولید بهتر HILLSHADE فردین آژغ 0 1,327 ۰۸-۲۳-۱۳۹۷، ۰۴:۲۰ ب.ظ
آخرین ارسال: فردین آژغ
  تولباکس جستجوی یک لایه در تعداد زیادی MXD فردین آژغ 0 1,274 ۰۸-۲۲-۱۳۹۷، ۰۲:۰۷ ب.ظ
آخرین ارسال: فردین آژغ
  تولباکس اکسپورت گیری از mxd ها به صورت گروهی فردین آژغ 0 1,541 ۰۸-۱۵-۱۳۹۷، ۱۱:۴۶ ق.ظ
آخرین ارسال: فردین آژغ
  کد شناسایی مسیر معیوب لایه ها در MXD فردین آژغ 0 1,240 ۰۸-۱۲-۱۳۹۷، ۰۵:۱۱ ب.ظ
آخرین ارسال: فردین آژغ
  مشکل در نصب ArcEngine mhd.amini 0 1,533 ۰۳-۲۷-۱۳۹۶، ۰۳:۱۰ ب.ظ
آخرین ارسال: mhd.amini
  برنامه نویسی تحت اتوکد محمد عباسی 10 11,494 ۰۸-۲۵-۱۳۹۵، ۰۲:۱۸ ب.ظ
آخرین ارسال: mehranolomi
  فرمول محاسبه مساحت با استفاده از مختصات shahrokh1 1 4,486 ۰۷-۱۱-۱۳۹۵، ۰۸:۵۹ ب.ظ
آخرین ارسال: erfankt19
  راهنمایی m.hamide7 0 1,553 ۰۲-۱۴-۱۳۹۵، ۰۲:۳۴ ب.ظ
آخرین ارسال: m.hamide7

پرش به انجمن:


کاربرانِ درحال بازدید از این موضوع: 1 مهمان

برای عضویت در خبرنامه جی آی اس ایمیل خود را وارد نمایید:

Delivered by خبرنامه جی آی اس